OfficeCommunity.com
The official WordPerfect Office Community.

Extremely slow opening documents

rated by 0 users
This post has 7 Replies | 2 Followers

Top 500 Contributor
Posts 4
pkmiller Posted: Thu, Jun 7 2012 11:46 AM

We just purchased new computers with Windows 7.  I am using WP x5.  Opening documents or navigating between different files is now extremely slow and seems to get worse as the day progresses.  Anyone have any ideas?  Our computer tech people told me to stop using WP and to use Word.  Uh.....that's not an answer!

Top 10 Contributor
Posts 714

pkmiller:
We just purchased new computers with Windows 7.  I am using WP x5.  Opening documents or navigating between different files is now extremely slow and seems to get worse as the day progresses. 

Since this just started happening, it is logical to assume something occurred -- or something did not occur that should have -- at about that same time to produce the problem.

Moreover, you didn't say if this happens on just one machine or on all machines, or exactly how you installed WP on the new machine(s). 

For example., did you "migrate" any program files from the old machine to the new one? Did you update your printer drivers for Windows 7? (WP makes very heavy use of printer drivers to produce true WYSIWYG on screen.) And so on and so forth.....

Perhaps something here will help:

For updating, upgrading and migrating tips: See "Updating, upgrading, or reinstalling WordPerfect" -
http://wptoolbox.com/tips.html#7 

For damaged documents or templates, see: http://wptoolbox.com/tips/RepairDocs.html 

- Barry -
Toolbox for WordPerfect
Tips, macros, and more
at http://wptoolbox.com

Top 500 Contributor
Posts 4
pkmiller replied on Thu, Jun 7 2012 12:58 PM

Thank you Barry.  We did a clean install of WP from the disk and then migrated over my documents.  We went in Tools and told it where the files were located.  I am the only one using Word Perfect.  My boss uses Word but he said his computer is much slower opening my WP documents now too.  Not sure if printer drivers were updated since the tech guys installed everything.  We did download the all patches for WP.

The files themselves don't seem to be corrupted.  It is just navigating around and opening them that is the problem.  Everything else works just fine.  I work in a law firm so we have numerous folders...closed files, open files, forms, each case has a file, within each case there are files for correspondence, pleadings, medical, etc., so I have to do a lot of navigating and it is taking forever!

I emailed Corel and they told me to set WP back at its default settings (but then they usually say that about every problem).  If I do that, would I lose all my macros?  Not a big deal I guess if I did since I could always make them over again.  Just wasn't sure how drastic this would be.  Do you think I should do that?

Peggy

Top 10 Contributor
Posts 714

Hopefully, you did not migrate over your default template to the new Windows 7 system. It is better to use the new default template and copy (migrate) customizations to it.

You won't lose your macros (in any case, I'm sure you have backups), but since this happened with a new, clean install, I doubt it would help -- but it can't hurt. Repairs don't usually involve user-created or user-modified files. See my linked pages above for how to do restore WP defaults.

Also, document and/or template corruption can be minor and yet the documents can still open without apparent fuss. It might pay you to carefully read the linked pages I gave you above. The more you know, the better you can troubleshoot.

For me, it seems that WP can't find the WP files very quickly, or else something is interfering. As noted on my links, one of the first things WP does is access the printer driver for the printer that was named in the saved document you are currently trying to open. If the driver is not up to date for the new version of Windows...you might have problems.

Your report of slow navigation to various Windows folders from inside WP is troubling, but I don't have any idea -- beyond "network issues" (whatever they might be) -- why this should be so.

Try copying a few documents onto your own Windows desktop (copy the actual files, don't just create a shortcut to them). Then open WP and use File> Open to navigate to the desktop and open the file(s) from there. See if it improves the navigating and/or file loading speed. This might tell us if there might be a network issue.

Then try creating brand new WP file on your Windows desktop -- just type (don't paste) a few words in it. Save it to the desktop, then exit WP. Then re-open WP and see if you have any problem navigating to it or opening it. This might tell us is the old documents have problems.

- Barry -
Toolbox for WordPerfect
Tips, macros, and more
at http://wptoolbox.com

Top 500 Contributor
Posts 4

It is much faster navigating files on my desktop.  I also typed a new document, saved it to the desktop, and had no problem opening it.  I assume the desktop is on my C drive.  My files are on an E drive. 

I forgot to mention earlier that we told my anti virus software not to scan WP.  I agree with you, it seems like either something is running in the background or it is looking for the file.  That said, whenever I exit WP and reopen it, it seems to work okay for a while and then slows more and more.  Every other program on my computer works fine...Word works fine...it's just WP.

Computer tech guy said they did download new printer drivers.

Peggy

Top 10 Contributor
Posts 294

Tech people think that Microsoft is the solution to all problems.  You can probably guess what I think about that.

Cleaning out your Temp folder is usually a good place to start.  I use ccleaner for that which cleans up other things as well.

Obviously, working from a thumb drive is much slower than harddrive files.  I say don't do that.  It is a problem waiting to happen.  Treat thumb drives like floppy disks.

As Barry said, printer drivers are critical for wp to work correctly.   If one is corrupt, it can gum things up.

Top 10 Contributor
Posts 714

pkmiller:
It is much faster navigating files on my desktop.  I also typed a new document, saved it to the desktop, and had no problem opening it.  I assume the desktop is on my C drive. 

OK -- we are making progress. :-)

My files are on an E drive.

If your E: drive is a network drive (a "share"), then it appears to me it might be a source of the problem, especially since you don't have a problem with WP files on your desktop -- which is just another Windows folder on your own computer (not a drive or folder on the network computer). 

See if the path set in your WP program's Tools, Settings, Files, Document tab, "Default document folder" is correctly set to the parent folder for all your WP files. Normally, on a standalone Windows 7 system, this is something like C:\Users\Barry\Documents. (Of course, your user name in the path would not likely be Barry.) 

Also: While you are in the Settings, check the "Timed document backup" -- leave it set to the default of 10 minutes (it should not be set to less than 5 minutes).

I forgot to mention earlier that we told my anti virus software not to scan WP. 

OK. But I doubt it is the problem, given what was said above. After you find the problem you can set the AV to scan the WP folder, too, just to be safe.

I agree with you, it seems like either something is running in the background or it is looking for the file.  That said, whenever I exit WP and reopen it, it seems to work okay for a while and then slows more and more.  Every other program on my computer works fine...Word works fine...it's just WP.

Perhaps it is something to do with the path to the network share where the WP files are stored.

Just a guess: Perhaps something is accessing that path to the extent that it is tying up the drive, such as a system utility program (defragger? auto-save program?).

If you are the only one using WP, then perhaps you can copy all WP files to your own, personal, new network share. This should be simple and quick for your IT guys to set up.

Then be sure to change the path in your Tools, Settings, Files, Document tab to "point" to the parent folder in that new share. Then reboot WP so it "reads" the new location.

If it works, then you have evidence as to where the problem lies. Even if it doesn't work, your IT people should be aware of the facts regarding putting WP files on your own desktop (i.e., no slow down). Clearly, something is an issue on the network.

- Barry -
Toolbox for WordPerfect
Tips, macros, and more
at http://wptoolbox.com

Top 500 Contributor
Posts 4
pkmiller replied on Fri, Jun 8 2012 11:28 AM

I think I fixed the problem.  I set WP back at its factory settings and remade all my macros.  Seems to be working like a charm now....knock on wood. :)

Barry, thank you for all your help.

Peggy

Page 1 of 1 (8 items) | RSS
© Corel Corporation. The content herein is in the form of a personal web log ("Blog") or forum posting. As such, the views expressed in this site are the views of the participants and do not necessarily reflect the views of Corel Corporation, or its affiliates and their respective officers, directors, employees and agents. Terms of use.