Problem with Drawing Tool (X5, Win7) - General Feedback - WordPerfect Office -

Problem with Drawing Tool (X5, Win7)

I am running WP Office on a Win7 (64 bit) machine. 

I have not used the drawing tool in quite a while until today.  I just tried to use it by clicking on the drawing icon in the main toolbar.  About 5 seconds after the tool appeared all of the icons across the top and down the left side of the screen disappeared.  I thought it might be because I had not upgraded to the latest version, so I upgraded to SP2 and tried again with the same results.  Can someone help me get the draw tool to work? 

Thank you for your help.

28 Replies

  • In reply to BobSing:

    On your #4:

    I suspect the confusion and your problem might indeed be related to what you use as the "default template." Normally, folks do not rename the default template. In any case, the currently active default template is always the one specified in Tools, Settings, Files, Template (tab).

    This is the one the program looks for when you create any new document with File, New. If it is corrupt, then the new blank document it spawns will be corrupt, too.

    Moreover, if you delete the wp15us.wpt file from the folder specified in the Template (tab), the program will spawn a new virgin copy of wp15us.wpt (assuming a US version of WP) when you next load WP -- but only if it was the one specifically named as the default template in Tools, Settings, Files, Template (tab).

    I am not sure (1) how you have set things up, (2) where "bob15.wpt" is physically located, (3) how it is accessed, and (4) whether this is the template you have named in Tools, Settings, Files, Template (tab) instead of the usual default template.

    Renaming wp15us.wpt when you are in fact specifying and using bob15.wpt would do nothing to help troubleshoot the issue, since the program would still be using the (possibly corrupted) bob15.wpt file. 


    1. First -- and most importantly -- read this page about "The default template (how to find it, modify it (see also this guide), and fix it) and custom templates" - I realize this will take a little time to read, but it should give you enough information about how things should be set up in a standard installation, and how to use various techniques to troubleshoot templates and create custom templates.

    2. Then -- for the purpose of testing -- verify that the WP "default templates" are physically located in the folder listed in the Tools, Settings, Files, Template dialog are temporarily moved elsewhere. (I suppose these are the "bob15us.wpt" and "wp15us.wpt" template files. Leave other template files alone, since this is also where the program keeps the QuickWords template.) Then, to make sure we are working with a virgin copy of the true default template, reload the WP program; it should immediately create a fresh copy of the wp15us.wpt template. The idea here is to use the specified Template location to spawn a factory fresh, default, wp15us.wpt template and then use it to test for problems (next step).

    3. Test the drawing tools in that new blank document.

    Try the above before trying to deal with updating the printer driver (I believe you said the system was working fine until recently). In any case you might need to disconnect the printer and close all programs. I'm no expert here -- you can go to your printer's web site for help -- but I recall instructions on my own computer about installing the driver before connecting the printer.

    I am not sure at this point if removing WP12 will help (you would use the Windows Control Panel), since we are not sure about the possible location of the problem. In any case, removing it and then repairing the WPX5 program should restore any Registry settings, common files, etc., for WPX5. But again, let's not get ahead of ourselves. :-)

    [Edited 3:22pm, 4-4-12]

  • In reply to BarryMacDonnell:

    Yes, my default template (which I have renamed Bob15.wpt) IS the one listed in Tools, settings, files, templates.  Each time I upgrade WP I change the name of the default template and the template location (which, like you, I have relocated under "My Documents" so that it gets backed up regularly). 

    Following your suggestions:

    1. I did read all of what you wrote under -  Yes, it was very long indeed.  However, there was a wealth in there.  In fact, I will be going back to it (after I get this solved) to do some new things, like create some custom templates with template macros (perhaps even ones which are automated :) ). 

    2. Next, I moved my default templates -  Bob15.wpt (the actual default template which is 254 KB) and wp15US.wpt which is 57KB - to another temporary location. 

    3. Then I tested the drawing tools in that new blank document (which had the margins at the default tabs every inch rather than my default of every 1/4 inch.  Unfortunately, it gave the same problem. 

    In the process of reading your tips on templates (above) I saw something which I have never done.  Although I have (obviously) created a new default template (with my own keyboard, menus, and toolbar), I have not ever gone to File, New from Project, Options and clicked "Refresh Projects".  Might this be something I should now do, or should I wait until this is all resolved and then do this? 

    I tried disconnecting the printer and restarting the entire computer.  But Win7 still told me it was in use when I tried to remove the driver. 


  • In reply to BobSing:

    Correction:  The factory default template has tabs every 1/2 inch rather than the every 1/4 inch in my custom default template. 

  • In reply to BobSing:

    RE: Your #2 and #3:

    I'm not sure I was clear in explaining this, since you are using a non-standard approach to a "default template". So ...

    If (1) you first went into Tools, Settings, Files, Template and changed the name of the default template to the standard Corel name (wp15us.wpt) in order to restore the standard setup; then

    (2) you exited WordPerfect completely; then

    (3) using Windows, you moved both the bob15us.wpt and wp15us.wpt templates from the folder that was shown in Tools, Settings, Files, Template (to remove any of your "default" WP templates from where WP would see them); then

    (4) you reloaded WP -- you should then be starting with a brand new, factory fresh default template (wp15us.wpt). If the problem persists in the new blank document then it's unlikely to be caused by the default template -- and probably not your bob15.wpt template, either.

    A thought:  I'm assuming that you have installed Corel Presentations as part of the WPO suite? WP's drawing tools and TextArt use it.

    The only other things I can think of are conflicts with other software, a corrupted Windows user profile (which stores some WP program settings) or other Registry issues, problems with the special Corel file folders (in your AppData older; this is described in the Corel support articles), and problems the printer driver (and/or communication between the program and the printer).

    I'm afraid I cannot help with updating your printer driver. 

    As a last resort, you may need to do a reinstallation of the program using the Corel "clean everything out first" method. Of course, if it's the printer driver, this won't help. But you can use Windows Control Panel to set another printer driver (such as the Apple LaserWriter) as a temporary default and then test WordPerfect for the problem.

    Sorry I cannot be of more help. It is (thankfully) rare to not find solutions to WP problems, but given that you may have any number of WP customizations and other variables to contend with that I cannot see from my vantage point, then I suppose this is forgivable.

    P.S. As I understand it, refreshing the Projects list is just refreshing the display of the various template names in the list, to give you access to all of them. The name of the Corel standard default template is shown there as "Create a blank document." (This display name can be changed:

    [Updated 10:28am, 4-5-12]

  • In reply to BarryMacDonnell:

    Thank you for your very thorough responses.  I have now followed all of your steps 1-4 above (including changing the name of the default template in Tools, Settings, Files, Templates back to the original wp15us.wpt), exiting completely from WP (checking processes within Windows Task Manager) and using Win to move the Bob15us.wpt and wp15us.wpt out of the folder designated in Tools, Settings, Files, Templates as the location for the default template.  Then when I reloaded WP15 I encountered the same problem with the drawing tools. 

    Yes, I did install Presentations as part of WPO.  However, I seldom use it.  So, I tried using it again.  Loading Presentations went fine.  However, there is another program called Presentations Graphics (in the Windows Start menu).  So, I tried loading it, without loading the main presentations file first.  When I did it came up and then immediately I received the error Presentations X5 has stopped working with a button to "close program".  Is this a problem or simply because this program is not intended to be loaded apart from the main presentations program?

    I will continue working on the other things you mentioned above (Windows User file, special Corel user files, and printer driver).  But I wanted to get this data to you since the drawing tools (as you mentioned) in WP use the presentations program. 

    Thanks again.

  • In reply to BobSing:


    ... Loading Presentations went fine.  However, there is another program called Presentations Graphics (in the Windows Start menu).  So, I tried loading it, without loading the main presentations file first.  When I did it came up and then immediately I received the error Presentations X5 has stopped working with a button to "close program".  Is this a problem or simply because this program is not intended to be loaded apart from the main presentations program?

    You should be able to load Presentations Graphics X5 directly from the Windows Start menu without any problem.

    Perhaps you have found the cause of your problems. ;-)

    Looks like a Repair or a reinstallation of the entire WPO suite, is in order:
    1. Try a Repair first.  It might help to clean out all Temp files on your system first, then reboot. (Sometimes disabling some A-V programs first also helps, but I've not seen a problem with installing/repairing WordPerfect with my own A-V program.)  Then: 
    Control Panel > Uninstall a program > select "WordPerfect Office X5" > click on "Uninstall/Change" at the top of the dialog > Choose the Repair button from the next dialog.
    2. If it fails to solve the problem, try following the steps under "Restore factory defaults" here: You may need to do another Repair afterwards (just a guess).

  • In reply to BarryMacDonnell:

    I followed all of these steps, including a longer-than-I-expected CCleaner cleaning.  Apparently it had been quite a while ;).  I did the repair first (with A-V off).  When that failed, i restored factory defaults following your guidelines in the link. When that also failed, I followed all of the steps (including more time in Regedit) of .  Then I reinstalled from the Corel Website, since I had originally done a download (not trial) install.  Unfortunately it did not solve the problem (even after updating the fresh install with SP2 from the Corel website.  This time in the installation, I installed everything (even Lightning) just in case I had left something out by omitting Lightning and Quatro Pro last time.  Again I tried Presentations (which was fine) and then Presentations Graphics which failed immediately in the same was as before. 

    New Idea:  Is it possibly because I have 2 monitors?  Is WP X5 and Presentations Graphics X5 not equipped for that? 

    Thanks for your tireless help on this perplexing issue.  Like you said before, my experience with WP and WP forums has been absolutely stellar for many years.  I started with WP 4.1 (yes, even slightly before 4.2).  So, my love for WP has a lot of history.  I have rarely needed to ask for help.  But whenever I have I have gotten incredible help from you, lemoto (Roy), Charles etc. 

    Any thoughts?

  • In reply to BobSing:

    Further note:  In these (post-reinstall) tests I had not done anything to the program related to customization (no change whatsoever to the default template location or anything).  I just went straight in and did the test. 

  • In reply to BobSing:

    Does this problem happen on your other computers, particualrly with the same printer driver installed?

    Were those other WP installs done from the same download?

    (Running out of ideas....)

  • In reply to BarryMacDonnell:

    Thanks for that idea.  Yes, I did use that download to install WP X5 on my two laptops. I need to put that printer driver on them to test that, which I can do in the morning.  Thanks.

  • In reply to BobSing:

    It might be a good idea to make a disk image of the boot drive before you install the printer driver, just in case.

  • In reply to BarryMacDonnell:

    I was not sure how to do a disk image of my boot drive.  However, I found one of the laptops already had the same printer installed on it, at least as a network printer (through the desktop computer of which we have been speaking).  WPO X5 was installed on this laptop as well through download. 

    When I tried the test it performed just fine, without any problems.  I also tried Presentations Graphics and it loaded just fine as well.  For the record, I have the same default template on the laptop.  Of course, it has a different history regarding what other programs have been loaded on it etc. The best guess to me seemed to be the dual monitors.  So, I tried different settings (display desktop only on #1, display desktop only on #2, extend the display, and duplicate the display), with all giving the same problem as discussed above. 

    Any other ideas, or do I need to just do any drawing on my laptop?

  • In reply to BobSing:

    Since you completely removed all traces of WordPerfect, and since the printer driver seems fine, then (to me) there is something about your system that is causing a problem in accessing Presentations drawing (and thus the drawing tools on the WP toolbar).

    What that 'something" is, is beyond my ability to troubleshoot from here. Short of starting fresh with a clean Windows system, I'm out of other ideas, sad to say......

    P.S. You can Google "create a system image in windows 7" and see how to create a full disk image. (I use Acronis TrueImage for that task, but the principle is the same.)