WPO X7 stops responding all the time - General Feedback - WordPerfect Office - OfficeCommunity.com

WPO X7 stops responding all the time

Hi

Ever since upgrading to X7 the program is unstable. It stops responding for no particular reason at all. I was using WIndows 8.1 at the time and tried uninstalling the printers, and changing the default printer, to no avail.

I recently installed Windows 10, hoping that the new operating system will end my problems with the unstability of WordPerfect X7, but unfortunately it did not. In the meantime our office also installed WordPerfect X7, and it seems to me that the very same problem arise there also.

Recently I tried to the solution to restore the factory settings in the registry, but the problem is still there.

What can I try other than the printer-solution and the restore of the factory settings?

Kind regards

Jaco Thom

4 Replies

  • "... It stops responding for no particular reason at all" might depend on which documents are being worked on at the time or other factors. Here's a page of troubleshooting tips that might help: http://wptoolbox.com/tips/RepairDocs.html

  • In reply to BarryMacDonnell:

    Hi Barry
    I tried the whole nine yards of your advice, and the stuff in the wptoolbox. The problem remains, unfortunately.
    It seems to me the document becomes unstable when I cut and paste from another file, especially when that file is not a WordPerfect document, even though I do an unformated paste. After such a paste the document stops for no particular reason, sometimes shortly after I did the pasting, sometimes minutes later. It helps to do a save without metadata, but not always.
    The problem does not happen in new documents, but as soon as I paste something, the trouble starts.
    I notice that my computer starts to run (hard drive activity?) when the document freeze.
    Kind regards
    Jaco Thom
  • In reply to Jaco Thom:

    Since, as you say, you have tried the various solutions described on my site, then we might be left with guesswork.

    Your feeling that it might have something to do with pasting into WP might be correct. "Trust your gut" is sometimes good advice since you might have noticed other contemporaneous factors when the problem surfaced that might be involved.

    Does it happen when pasting the SAME material into a new, empty document or only when pasting that material into an existing document? The former could indicate a problem with the pasted material (or with the default template); the latter could indicate an issue with the target document(s).

    Does it happen when pasting a small amount (a few paragraphs or a few pages) of PLAIN text from the current document or another document? If not, maybe the source material is corrupted. (Not only pasting images, but pasting with formatting, tables, etc., can be problematic.)

    Inasmuch as you have the same problem with other computers, my guess is that it could be a WP setting -- such as the WP automatic backup being set for a too-short time interval. See under Option #1 at http://wptoolbox.com/tips/AutoBAK.html . Pasting into a document from another source can involve conversion activities (e.g., images), so there could be program activity that might not be finished when the next automatic backup period starts.

    In effect, increased disk activity at the time the program freezes could indicate the program can't do something or can't find something.

    Did you also try fixing the default template (and here I assume it's the one the program installed, not a copy of an older template)? It "spawns" new documents, and if it's damaged it can send the damage to the new document. It's easy to fix. For information on the default template and custom templates -- how to find, create, modify, or fix them, etc. -- see http://wptoolbox.com/tips/Templates.html

    Also: Is your WPX7 up to date? Corel has Service Packs on their Support page: http://www.wordperfect.com/en/pages/800161.html

  • In reply to BarryMacDonnell:

    Thanks for your advice. I shall look into the paste issue. I recently upgraded to WPO X8, and unfortunately it also freezes, just like X7.
    Kind regards
    Jaco