WPX8 always becomes unresponsive after being left idle - General Feedback - WordPerfect Office - OfficeCommunity.com

WPX8 always becomes unresponsive after being left idle

I purchased WPOX8 last year and found it generally very good.  But one annoying thing that always happens is that Wordperfect freezes up after being left idle for a while, requiring a close through the task manager where it shows up as "not responding".  I have never tested how long it takes, but I suspect it is after about half an hour.  I don't lose any work through this as I always save before walking away from the computer.  This consistently happens on three different PCs that all run Windows 10 64bit (two are enterprise and the other pro).  All three machines are set to never sleep and don't have screensavers set or monitor set to turn off after a period.  Has anyone else struck this issue and will be fixed with an update?  I have never struck this with previous versions of WP (last was WPOX6).

12 Replies

  • In reply to tlnett:

    But as I pointed out in the question, these computers are set "never" to sleep - I had already checked this after reading these other threads first.
  • Just to help you know it is not peculiar to you, I have had the same experience consistently, also under Windows 10 Pro 64-bit. (And also with all power saving turned off - always irritating when people do not bother to read carefully.) The time to freezing seems pretty variable, but never seems to occur quickly (that is, it does not freeze after a short time idle, it always takes a while). I have tried repairing the installation with no improvement. I cannot discern any interaction that would explain this, although I do not have WP X8 installed under varied hardware and software environments that would help narrow this down. This has occurred ever since I installed X8 last spring.
  • In reply to Solidornot:

    Thank you Solidornot. I have thought about this a bit further, and upon investigation, I found that even though the computers are set "never to sleep", in "advanced settings" the hard disk is set to turn off after 20 minutes, and I think this may be the source of the problem. I cannot change this setting on my office machine as that setting is one tagged as "managed by your organisation" (windows 10 enterprise). However, I will try turning off the autobackup feature in WP (which I have never had to use anyway) as I suspect it trying to autobackup to a hard disk that is turned off may be the trigger for the freeze-ups. I will report back on any result.
  • In reply to Landy:

    ... However, I will try turning off the autobackup feature in WP (which I have never had to use anyway) as I suspect it trying to autobackup to a hard disk that is turned off may be the trigger for the freeze-ups. I will report back on any result.

    I doubt the WordPerfect automatic timed backup feature is the culprit since it does not activate unless there has been at lease one change made to the document while editing that document. We might presume the hard disk which stores this backup file (see below) is not turned off when you are editing and saving the document -- but if it is, then any save-to-disk operation, manual or otherwise, should start the disk spinning again (assuming it's not a SSD). If it didn't you'd be unhappy because the machine would appear "bricked".

    The automatic timed backup (if enabled) would try to write a backup 10 minutes after a change (10 minutes is the default, but it can be changed). This seems to be a bit less than "a while". So I'm not sure it's a good candidate for the cause of your problem.

    And too short a delay in auto-saving can present the problem of one backup not being finished before the next one begins.

    It sounds to me like something else is at fault.

    Just a guess: I suppose the disk on which the backup is made (specified in your program's Tools, Settings, Files, Document (tab), "Backup folder" field) might be on a network share that is not available, which might account for the program freezing. (Sometimes it can take several minutes for the computer to access the network.) If this is the case then it will be interesting for me to know so that I can update my site.

    For more on the two WordPerfect automatic backup features see Automatically make back ups of your [WordPerfect] document to help you recover your work at http://wptoolbox.com/tips/AutoBAK.html. See especially the section entitled "With the timed backup feature enabled ... ".

  • In reply to Landy:

    I've had email notification of a response from Barry MacDonnell which does not show here on the thread, but I will respond anyway. Barry suggested that it was unlikely to be the autobackup feature which was triggering the freezes, and he may well be correct. He also suggested that it may be that the autobackup folder was on a network drive, however, that is definitely not the case. This same fault occurs on my home PC which isn't even networked. So the mystery remains. I will disable the hard drive "turn off after 20 minutes" option on the machine at home and see if that stops it happening.
  • In reply to Landy:

    Sorry about the missing reply to you in this thread.

    I had been editing my reply (Post, then Edit) severtal times, and at the end of this the dumb software here refused to let me post again. I assumed that a moderator needs to ensure I was not a spammer and then re-post my reply, but no such luck.

    I guess this is a warning to all of us to NOT do much multiple Post/Reply editing here. :-(

    FWIW this does not happen on WordPerfect Universe (www.wpuniverse.com) -- which in any case is a much more active site for peer-to-peer help with WordPerfect. As of today it has:

    Threads 34,734
    Posts 255,992
    Members 17,444

    It's free to join (though it might take a few days for new members to be activated).
  • In reply to tlnett:

    Has anyone found a solution to this? This happens to me a few times a week. Did a clean re-install, made sure all updates/patches were up to snuff, changed my power settings as described here - still happen.
  • I have had this problem with WordPerfect going back, what, 20+ years? Maybe since WP was on floppy discs. I now am using WPx8 & it's guaranteed that the program will freeze on me several times during a project--I will have to close the program and then open it again. I've tried all the so-called fixes. Because I can say with a certainty that I have had this problem since the beginning of time--on many, many different computers---the problem must be WP's. I just don't understand why WP cannot fix the problem. I am writing this now because WP has frozen on me so many times tonight, I can't count & I'm mad as hell. I am one of the few people left who still uses WP. If I can figure out how to do a Table of Contents/Authorities in Word & some other similar functions--I'm on the verge of cutting the chord. But, I guess if we are dumb enough to keep buying a product despite years of known defect, I guess we're getting exactly what we deserve.
  • In reply to HollisHoHo:

    Do you have this problem on a standalone computer, not attached to a large network? Perhaps some resource (printer or printer driver?) not properly accessible on the network is the problem.
  • In reply to frisbee:

    It doesn't matter if my printer is is plugged directly into my computer (95% of time) or my home network. The problem has nothing to do with printing or network. I've tried every tip & trick that has been tossed around for years as a fix for the same problem...from wpfix to unchecking enhanced file dialogue to reinstalling program to reinstalling updates, etc. etc. I have been researching a fix for this problem for years. I'm sure you can find me ranting & raving a few years back on WPUniverse for the same thing.
  • In reply to HollisHoHo:

    Printer problems, including from printers you are not using, can hang or appear to hang the system. Try getting rid of unused and unnecessary printers in Control Panel, Devices and Printers. Even though you describe your problem as occurring after the program has been idle, the circumstances causing the problem are not always clear. 

    Another thought: try turning off your antivirus or firewall program for a while. Look through the antivirus and firewall settings to make sure Corel isn't being blocked. 

    Ron S.