Missing features - General Feedback - WordPerfect Office - OfficeCommunity.com

Missing features

I'm Carl Childress, and I write a book called The BRD, which covers the differences in baseball rules among high school, college, and summer (pro) leagues. I have over 1000 targets, more than 1600 cross references (hyperlinks), hidden text and counters, etc. There is no question WP is the ONLY wordprocessor with the capability of creating this complex reference work.; The 30th edition comes out in November from amazon.com. It's been in WP since WP 5. (Before that, WordStar.) Never, never Word.

That said: In X6 two very convenient tricks no longer work. In X5 (without the service pack), when I clicked on the cross referencfe toolbar (Select Target), the click automatically selectred the text inside the box. That made it possible to easily enter a complete new target. Now, I have to scroll the text to select before I can Ctrl+V the new target text. Most irritating. (In X5, the service pack also didn't select automatically. I deleted and re-installed the program. To heck with the Service Pack. But now, it's built in.) As I said: MOST irritating.

But, even worse: I hide all hyperlink bookmarks from the \pinted version, but display them for what's known as the EBRD, which allows readers (and me) to navigate through the documeet. (400 pages, 200,000 words). In X5, when the hyperlinks are displayed and I scroll over the linke, the bookmark shows.  That makes it possible to known instantly that the link is live. Now, I go there, and the pointing finger just points, with no "tip" on display. That's going to cost me  about 100 hours of extra worki. Very, VERY IRRITATING.

Does anyone have a fix? a workaround? Is anybody at Corel listening?

33 Replies

  • In reply to carlchildress:

    carlchildress
    If you're not using X6. then you cannot replicate my error. If' you're using X5, it's simple. Create a link to a bookmark somewhere in a document. Give the link a visible form, then select it, format: font: hidden, and you can display/hide with the toggle.

    I was going to installk X5 again, but as I suspected, I cannot as long as X6 is on the computer.

    As I stated above, I am using WPX6 ... and WPX5 and WPX4 ... all on the same Windows 7 computer. I cannot replicate the problem using any of them. The tool tip -- or "hover tip" if you prefer -- displays in all of them when the cursor is over an active hyperlink. ("Active" vs. "inactive", and what happens to the state of activation when you save the document, was discussed in my first post.)

    From this you should be aware that you are incorrect about not being able to install multiple versions of WP on the same computer. I have had as many as seven versions on the same computer at the same time -- all of them peacefully coexisting. When you want to do something similar, see http://wptoolbox.com/tips.html#7 on my site for some tips.

    Again: I still cannot replicate your problem, nor can heather or Roy, other than as specifically indicated in my previous posts. But that result apparently has to do with the window that has the "focus" (assuming the hyperlink is indeed "active").

    Do not try to view the hyperlink.l That appears to be your error. While the link is dis[played in X5, "hover" on it and you'll see your bookmartk. No need to open or edit or any thing.

    As I stated above, I am hovering over the hyperlink. I am not trying to view or edit the hyperlink.

    Have you carefully read all my posts? You still have not answered the same question I posted twice about "focus." Without feedback from you we are going in circles.

    P.S. I have hosted a web site to help WP users since 1996 (see the link below my name). I am well aware of how to assign a feature to a keyboard shortcut. (See http://wptoolbox.com/tips/Assign.html ). But I don't believe that is the issue here.

    P.P.S. When replying, it will help if you indicate who you are replying to.

     

  • In reply to BarryMacDonnell:

    So now that we know we are all talking about the same thing - my conclusion would be that either

    1. there is something different about the document (which if the same problem appears in a new doc eliminates that possibility); 
    2. there is something wrong with the default template (which I think unlikely as this document was created in a previous version);
    3.  there is something not quite right with the install - so try a repair
    4. Try under a different Windows user account to eliminate settings or AppData issues

    I've also seen all these items eliminated as possibilities and it ends up being a conflict with another program/driver ruining. These are very hard to track down, although sometimes running in Safe mode can confirm the issue is with another process that is typically running in regular mode.

  • In reply to HeatherB:

    Heather,

    To your list I would add:

    5. The hyperlinks were inactivated using the Hyperlink Toggle on the property bar (or Hyperlinks Tools toolbar), and the document was saved with that choice. The hyperlinks in that document would then remain inactive when the document was re-opened (until re-activated the same way), and the tool tip would fail to display. This was proposed in my first post.

    6. The user was working (typing) in another program window and then moved the mouse to the WordPerfect window, where hovering over a hyperlink displays the pointed finger cursor but fails to show the corresponding tool tip (at least, on my Win7 system). This was proposed in my second post.

    7. If a document bookmark to which a hyperlink was assigned to is missing or renamed, the tool tip will not appear. I suppose if the document is internally corrupted so that all or most bookmarks or links are damaged, the same thing might happen. This brings us back to your first points.

    But #6 is still an open question in this thread, since we have not had feedback on this point from Carl.

  • In reply to BarryMacDonnell:

    Well, by all means, let me "feed back": I'm talking to Barry and anyone else who may have taken part in this business.

    First, X5 will not install on my  computer. I'm running XP professionial service pack 3. After 15 minutes or so, here is the error message: Your system has not been modified. To complete installation at another time, please run set up again. Another version of the product is already installed. Installation of this version cannot continue. To continue or remove the earlier version of this product, use Add/Remove Programs in the Control Panel. Click Finish to exit the setup.

    That's clearly a Windows message, but it appears in a WordPerfect X5 window, complete with logo. Yes, I installed in a different folder. My X5 and X6 are full professional versions, not a student rip-off, etc.

    Next:

    I have no explanation, but: Though I have made no modifications in X6, the links now display the text of the bookmark. Consequently, I don't need to reinstall X5. Consequently, I am no longer in need of your gracious help.

    I still don't like it that a click in the Target window of the Reference toolbar does not automatically selecft the text. But I did get a workaround.

    I thank all for your time. You can read about my book at Amazon.com: The 2012 BRD: Baseball Rule Differences. Only WP could handle the demands I put on the word processing program. It's why WP is the choice of all professional writers. Google my name: Carl Childress baseball. 

     

  • In reply to carlchildress:

    carlchildress
    ...X5 will not install on my  computer. I'm running XP professionial service pack 3. After 15 minutes or so, here is the error message: Your system has not been modified....

    This message exists in the Corel Knowledgebase:

    http://corel.force.com/index/articles/en_US/Master_Article/000011399-WordPerfect-Office-X5-Another-version-of-this-product-is-already-installed?

    I have no idea if this will help or not.

    I have no explanation, but: Though I have made no modifications in X6, the links now display the text of the bookmark. Consequently, I don't need to reinstall X5. Consequently, I am no longer in need of your gracious help.

    OK ... let's classify it as a Gremlin. :-)

    I still don't like it that a click in the Target window of the Reference toolbar does not automatically selecft the text.

    If Heather finds a solution I'm sure she will post one. Check back here once in a while.

    I thank all for your time. You can read about my book at Amazon.com: The 2012 BRD: Baseball Rule Differences. Only WP could handle the demands I put on the word processing program. It's why WP is the choice of all professional writers. Google my name: Carl Childress baseball.

    You're welcome. Glad to see WordPerfect is up to the job.

     

  • In reply to BarryMacDonnell:

    BarryMacDonnell

    carlchildress
    ...Another version of the product is already installed. Installation of this version cannot continue. To continue or remove the earlier version of this product, use Add/Remove Programs in the Control Panel. Click Finish to exit the setup.....

    This message exists in the Corel Knowledgebase:

    Hey Barry,

    In this particular instance, I believe that error message is due to having a newer version of the WordPerfect IFilter already installed on the system.  This was rectified for WPO X6, but the WPO X5 setup had an issue that caused it to fail when it detected another version of the WordPerfect IFilter on the system.  To install WPO X5 after WPO X6, simply uninstall the X6 IFilter; after that, WPO X5 should install without any issues.

    Once WPO X5 has been installed, you can always download the newest IFilter off Corel.com (from the Patches & Updates page) and re-install it separately.

    I figured you might find that info handy in the future.

  • In reply to pascalc:

    Pascal:

    How do I uninstall a component (IFilter) in X6? I can follow the directions of how to reinstall it. (grin)

    BTW: When I installed X6, the installer informed me it would, whether I liked it not, uninstall the "previous" version.

    Thanks in advance.

  • In reply to pascalc:

    Pascal:

    Thanks very much. 

    Is this information in the KB yet? An uninstall/install guide for users might be helpful, and I can link to it on my site.

    Is the WPX6 version of iFilter required for optimal performance of WPX6?

  • In reply to carlchildress:

    Hi Carl,

    The IFilter has a separate entry in the Windows Control Panel's "Add or Remove Programs" dialog, called "WordPerfect IFilter 32 bit" and/or "WordPerfect IFilter 64 bit".  Simply click the Remove button and you should be good to go.

    Glad I could help,

  • In reply to BarryMacDonnell:

    carlchildress
    BTW: When I installed X6, the installer informed me it would, whether I liked it not, uninstall the "previous" version

    Carl:

    When I installed WPX6, one of the first screens ("Disk Clean-Up") had optional choices to remove previous WP versions. It was not required to remove any earlier version.

  • In reply to BarryMacDonnell:

    BarryMacDonnell
    Is this information in the KB yet? An uninstall/install guide for users might be helpful, and I can link to it on my site.

    I couldn't find it on our Knowledge Base.  I'll see what I can do about getting it added.

     

    BarryMacDonnell
    When I installed WPX6, one of the first screens ("Disk Clean-Up") had optional choices to remove previous WP versions. It was not required to remove any earlier version.

    Carl's correct about this.  When installing WPO X6 over WPO X5, the X6 setup notifies users that the current IFilter will be replaced (and the option cannot be unchecked).  This is on the Options page of the setup wizard, instead of the Migrate/Upgrade pages.

  • In reply to pascalc:

    Oh...my mistake.  (I thought Carl was talking about the installation routine requiring that the whole previous program be removed, since he said he had done that with his WPX5.)

    BTW: Is the iFilter for WPX6 required for optimal performance in WPX6?

  • In reply to BarryMacDonnell:

    BarryMacDonnell
    Is the iFilter for WPX6 required for optimal performance in WPX6?

    No, the IFilter is essentially a plugin used by third party search tools (such as the Windows Indexing Service / Windows Search) to index the contents of WordPerfect files.  It is not used by WordPerfect Office itself.

  • In reply to pascalc:

    Great, thanks. I notice on my Windows 7/64bit system there are two versions of the IFilter file: WordPerfect IFilter 32 bit and WordPerfect IFilter 64 bit. I assume both should be removed before attempting to install WPX5 on a system with WPX6 already installed.

  • In reply to BarryMacDonnell:

    BarryMacDonnell
    I notice on my Windows 7/64bit system there are two versions of the IFilter file: WordPerfect IFilter 32 bit and WordPerfect IFilter 64 bit. I assume both should be removed before attempting to install WPX5 on a system with WPX6 already installed.

    Correct.  This will be the case on all 64-bit versions of Windows.