Trying to run WP X7 results in icon flash, then nothing

Running Win 7 home premium on an ASUS motherboard, Intel Core i7, plenty of RAM & user space.  

Several months ago I migrated my main drive over to an SSD via cloning.  Everything worked great.  

This morning I downloaded & ran WP X7 SP2.  The update gave me an "Error 1327. Invalid Drive E:\", after which the "print" box was grayed out and I couldn't print anything.  There is no E:\ drive any more, after the SSD installation.

I tried:  

1)  updating several more times (no change)

2)  uninstalling WP X7.  It was unable to uninstall under Windows 7 or using JV16 Powertools.  I tried to rename the pertinent registry entries from E:\ to C:\, but Windows Core would not allow that.  Deleted all deletable WP X7 registry entries (backed up), ran an uninstaller tool from Microsoft that seemed to do the trick.

3)  reinstalled WP X7 from DVD.  Seemed happy, no error messages.  BUT when I click on the WPX7 desktop icon, all I get is a flash and then nothing.  When I check Task Manager, WPX7 indeed is not running. 

Restored deleted registry keys.  No change.

At this point I'm worried that I'm going to have to reinstall Windows which I have done before, but I have a lot of applications and would prefer not to dedicate a full week or so reinstalling and downloading everything.  SInce I don't have a cable modem.  

Any suggestions as to how to completely uninstall WPX7 so I can reinstall it, would be very welcome.  I've been using WordPerfect since the DOS days, and never been stumped like this.  

  • After 12 hrs found a 2-step solution to the problem:

    Step 1 - getting rid of the Error 1327: Invalid Drive E:\ error

    This YouTube video gave the key: